
Your HyperStudio application MUST be version 3.1 for both Macintosh and Windows and must be set to “Experienced User”.  At the
HyperStudio Edit menu, choose “Preferences”, and  check “I am an experienced HyperStudio user.”

Using Graphic Filters in HyperStudio
What are filters?
Filters are program add-ons which create specific visual effects, such as beveled images, “glass eyes”
and fractals, quickly and easily. Filters, were originally designed to enhance the usefulness of Adobe’s
Photoshop --you might know them by the name Photoshop Plug-ins. You can now use these graphic
filters right within HyperStudio.

HyperStudio comes with 4 pre-installed filters: Beveler, Texturize, Brightness/Contrast, and Emboss.
Some filters work with both rectangular and lassoed selections, some (such as beveler) only work
with rectangular selections.

If you wish to add more filters to HyperStudio, simply copy the filters into the Plugins folder in your
HStudio directory (Windows) or HyperStudio for HD folder (Macintosh), and restart HyperStudio.  The
filters will then be available from the HyperStudio Edit and “Effects” menu.

Using the Beveler Filter in HyperStudio
Beveling an image gives it a three dimensional look and is great for creating HyperStudio
buttons.

From the File menu, choose Add Clip Art, choose any photograph and select an area about 1
in. by 1 in.  Once it is floating on your card, move it to one side. Do not place it on your
card by clicking away from it,  you need to have it still selected. If you did click away from
the Tools menu, select the image with the square selector on the Tools menu. While it is still
selected, hold down the Ctrl key (Windows) or the Option key (Mac) and move over your
image until your cursor changes to a four directional arrow. Once the cursor has changed,
use your mouse to click and drag the image to one side of your card. As you drag you will see
you are moving a copy.  You should now have two images.

While the new image is still selected, go to the Edit Menu, choose Effects, and Beveler.  On
some machines Beveler may be in a sub-menu of Effects called HyperStudio Effects.
Select the number of pixels for your bevel (8 is a good number), check the box next to “ Flat”
and click OK. You will now have a beveled piece of clip art.

*Continue if you would like to do Roll Over Buttons explained later.
Using the square selector tool from the Tools menu, select your original image. Once it is
selected, go to the Edit menu a and choose Effects and Beveler. Choose the same number of
pixels, AND check the box next to “inverse”.  Your picture is now beveled inversely. Select this
picture with the selector tool again, go to Objects, and choose Add a Graphic Object. A
dialog box will appear, click “Yes”.  At the Graphic Appearance menu give your object a
name, then click on the Features button and put a check in the box next to “Hidden”.  Click
“OK”. (We will be using this graphic object later in the tutorial.)

Adding more filters to HyperStudio
There are literally hundreds of graphic filters available for people to use.  Some are commercial
products, but many others are available for free off of the Internet.  You can find hundreds of freeware
and shareware filters, as well as links to other graphic filter resources at “PC Resources for
Photoshop”:  http://www.netins.net/showcase/wolf359/adobepc.htm

HYPERSTUDIO GRAPHIC TECHNIQUES.
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At the Actions Menu, choose New Button Actions.  At the New Button Actions dialog box,
highlight HideShow 2. If it is not in your samples window, choose disk library and navigate
out to HyperStudio’s “NBAs and Extras” folder or out to the More NBAs folder in the
HSUtilities/Utilities directory on the HyperStudio Resource CD.  Once HideShow 2 is
highlighted, click on “Use this NBA”.

At the HideShow 2 dialog, type in the name of the object (you named the object earlier after
beveling it and changing it to a graphic object), check the kind of object it is (text, graphic,
button), and whether you would like the button to show, hide or flip the object. Your object
is a graphic and you would like to show it. Click “OK” when your settings are satisfactory.
Click “Done” at the Actions menu.

A visual signal can also be sent to a user by using an interactive cursor.  This cursor can
change its appearance when it passes over a button or graphic object. This may be used as a
signal to the user to click an invisible button.

In the lower left corner of the Object Features dialog box is a pull down menu which lets you
assign the cursor which will be displayed when the user moves their mouse over the button.
Click and hold your mouse on “none,” then drag your mouse down to select the desired
cursor icon.  Click “OK”.

From the Objects Menu, choose Add a Button.   At the Button Appearance
menu, make sure the “Highlight” box in the lower left corner is un-
checked. Choose the Type of your button to be the Invisible Square button
type.

At the Button Appearance menu, also click on Features.  At the Object
Features dialog box, check the box next to “No-Click”.  This means your
button will activate as soon as the mouse moves over the area of the
button.

Roll Over Buttons
With a Roll-Over Button, an image or word appears or changes color when the user passes their mouse over it, signaling them to click the
mouse to activate an action.  This can be done by using a hidden graphic or text object which is shown with a no-click, invisible button
running a Hide/Show NBA.

Interface Design
All multimedia projects have an interface.  This “environment” consists of visual, textual, and audio symbols, your user interacts with and
uses to gain navigation information.  An effective interface gives the user standard or easily recognized symbols or words to interact with.
For some great infomation on using graphic filters and techniques to create interface designs for HyperStudio projects, go to http://
www.schoolvision.com/drmitchell

Follow the same steps for your button, only choose “hide” at the HideShow 2 dialog box. Your invisible button should be larger than the
previous button, so that when you move off the hide button, you move over the show button. If your button no longer hides your graphic,
it is probably a layer behind this new larger button. Choose your arrow tool, from the Tools menu, highlight the larger button and go to
Objects, Send Farther. This may take a few tries, so experiment with the various layers. Remember: you now have 4 layers on your card.

Define the shape of your button, matching the placement and shape of your Graphic Object,
and click to the outside.

Make sure you are in browse mode and move your mouse over your button. Your graphic should hide revealing the clip art below.

Making Your Original Art Re-appear



Gradients
Gradients can be used for anything from backgrounds, to creating sky, to adding color to a birds wing, to adding dimension to an object.
You can use a gradient to fill any selected area on the card.

Filling a Selected Area with a Gradient:
You can use gradients to add depth and shading to art you create in HyperStudio. By using
gradients of two different colors or two different shades of the same color, you can make your
projects jump off the page.

Tear off your Tools palette and your Colors palette. You can do this by dragging your mouse
past the bottom of the Tools palette at the Tools menu. When your mouse moves past the
bottom of the palette, you will see a “ghost” image of the palette. Simply move the palette to
an unused area of your card. Once you have a floating palette, to move it around, click your
mouse on the bar at the top and drag to a new location. To close the palette, click in the small
square to the upper left of the palette.

Using the Paintbrush and Paint bucket from the Tools menu, draw an image on the back-
ground of your card. Make sure the image is completely solid.

Using the lasso tool on your Tools palette, lasso one of the images on your card. When the
image is selected, go to the Edit menu, choose Effects and Gradients. Pick two contrasting
colors or shades and choose a direction for your Gradient. Think about where you might
want a light source hitting your objects. Try to keep that light source consistent for all of the
images on the page.

Lasso each of the images on your page, and fill each with a gradient. Hint: if you hold down
the CTRL key (Windows) or the Option key (Mac) and click inside one of the objects with
the lasso tool, the lasso will “expand”  to fill that object. If you click your mouse outside
of the object, it will select the entire area outside the object (providing that area is a
solid color).

Once you have added gradients to each of your objects, use the rest of the paint tools,
patterns, and colors to finish your drawing.

Hint: Once your images have been finished, but before you complete your background, you
may want to do a File, Export Screen. By exporting and storing this picture, you can use these
images over and over! Use Scale, Rotate, Flip Sideways, and Flip Upside Down from the Edit,
Effects menu for a variety of  results.

Using Gradients:
From the Edit menu choose Effects, and Gradients. If you do not select an area on the card, HyperStudio will fill the entire back ground
with a gradient. Choose the two colors for your gradient, as well as the gradient style (Vertical, Horizontal, Circular, or Rectangular). Click
“Apply”.

Now use any of the three selector tools, square, circle, or lasso,  to select the area on the card.  From the Edit menu choose Effects, and
Gradients.  Choose the opposite gradient or a completely new one and click “Apply”.



Creating a Drop Shadow Title Using Cookie Cutter:

From the Tools Menu, double-click on the Text Tool (the Tools pallete must be floating above
your card).  At the Text Appearance box, choose a  Font, Color, and Size for your text.  Large,
thick fonts with letters that are close together work the best. Once your text style is set, click
OK.

Click on the screen to place your cursor. Type your Title on the screen. We’ve used the
word“Text” as our title.

Add a pattern to the background of a small area of your card. The pattern to the left was
created with the Paintbrush tool and the patterns on the Colors Menu, but a small box with a
picture, texture, or gradient will work just as well.

With the Lasso Tool, select your text.  Once your text is selected, hold down the ctrl key
(Windows), or option key (Macintosh), and drag your selection onto the gradient. When you
do this, you should be dragging a copy of your text. Make sure you have moved over your
selected area, (your cursor will be a four directional arrow) before clicking with the mouse.
Do not click away from your selection after you have moved it. The text must still be
“floating” above the pattern. If you click away from the text, it will become part of the pattern.

From the Edit Menu, choose Effects and Cookie Cutter.  The pattern from your background will
be “absorbed”  into your selected text.  Again, do not yet click away from your selection.

Drag your selection back up over your text, and place it several pixels up and to the left of your
original.  Now click on the card to the outside of your selection.  This will create the visual
effect of a drop shadow on your text.

Try this same technique with an image or gradient instead of a pattern, or use it to give texture
to shapes and forms you have drawn.

Creating a 3D Box Using Gradients
From the Edit menu, choose New Card. You must have a solid color
background on your card.

From the Extras menu, choose Box Maker.  Draw a rectangle on your screen
and release the mouse button, Box Maker will then  create a floating three
dimensional box. Once you have the shape and direction determined, click
your mouse button again to place the final box on the screen.

Use the eraser tool from the Tools menu to erase any extra lines, so that you
only see three sides to your box.

From the Tools menu, choose the lasso tool.  Hold down the ctrl key
(Windows), or the option key (Macintosh), and click once inside on the
“top” of your box.  The lasso will “expand” to select the entire area.

From the Edit Menu choose Effects, and Gradients.  Select a vertical gradient
which has light color at the top, and a darker tone of the same color at the
bottom.  Click OK to fill the selection.

Follow the same process to fill a “side” of your box with a horizontal gradient.
Use the paint bucket to fill the “front” of the box with a solid color.

Cookie Cutter
The Cookie Cutter feature fills a selected area with the background image. You can use the Cookie Cutter feature for creating wonderful
effects with faded images, titles, and drop shadows.
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